Just Bought a FZ6R with a 2 Brother pipe and it runs like a pig. HELP !


Markyboy61

New Member
I just picked up a 2009 FZ6R (with 2,000 miles on it) for my wife to ride and it has a Two Brother exhaust system on it. It is loud but runs like a pig. From idle to about 4,000 rpm it stumbles all over the place. The bike does not have a Power Commander. I thought with a Fuel injected bike that they could compensate a bit for the pipe and you would only need a Power Commander if you wanted to really dial it in. DId I buy a bike with some other issue or does this thing need a Power Commander and fuel map.
 

Bikelife89

New Member
Check the plugs out and make sure the tank has fresh high oct gas in it . It shouldn’t be that bad I have full exhaust and no pc and it’s fine rides great
 

Markyboy61

New Member
Thank you for the reply. That is not good news. I just assumed that the full exhaust with no PC was the issue. The bike has 2,000 miles on it but the 1,000 - 4,000 it runs terrible. I rode it home last night and was ok on the highway.
I bought it for my wife who is a new rider and I would not let her on it the way it is.
I don't know that bad plugs would make it run as bad as it is but worth a try.
I hope the plugs are easy to get to
Thank you for the feedback
 

Bikelife89

New Member
For that low of miles and it running good on highway I’m hoping it’s bad gas . Had it been sitting not being rode much
 

Markyboy61

New Member
I don't think it had been sitting any longer than over the Winter (Not Sure). I think I will try draining the gas and filling her up with fresh High Test Gas.
I may stop at my local Yamer Dealer and pick up spark plug, oil and filter. (That should probabgly be done anyway)
I can't imagine spark plugs with 2K on them would make it run that bad but it may be worth a fresh start with everything.
 

vcdstroyr

Member
I don't think it had been sitting any longer than over the Winter (Not Sure). I think I will try draining the gas and filling her up with fresh High Test Gas.
I may stop at my local Yamer Dealer and pick up spark plug, oil and filter. (That should probabgly be done anyway)
I can't imagine spark plugs with 2K on them would make it run that bad but it may be worth a fresh start with everything.
Don't go to stealership. Go to bike bandit for the plugs and go to walmart for some Shell Rotella T6 and pick up a filter from somewhere (cycle gear or amazon).
 

Just_Jim

Member
OP, don't throw a bunch of money at your bike until you've narrowed down the potential problem.

Definitely drain and refill the fuel (regular gas will do, using premium is just a waste of money and no benefit to performance - this bike was designed to run on regular gas) and for sure change the oil and filter.

BTW, you can pick up an oil filter at most auto parts stores. The Mobil 1 M-110 filter fits the FZ6R. I've used this filter on my R6 for years and get them at AutoZone..

I'd hold off on the spark plugs until you've ridden the bike with fresh gas in it for at least a full tank. With just 2,000 miles on your bike, the plugs are probably fine and old gas is causing your issues.
 

Just_Jim

Member
One other thing, it's probably still got the original tires on it. If I were you, I'd replace them, no matter how much tread they have. 10+ year-old tires are not something you want to ride on for very long.
 

milepig

Member
I've got a stock exhaust off my wife's 09 fz6r you can have if you want. You'd just have to pay shipping cost. FWIW, she has the 2 brothers header and can, controlled by a Juicebox, runs great.
 

Markyboy61

New Member
Thank you for the feedback.
Over the Holiday weekend I drained the old gas out and put in fresh gas and Star Tron. No Change.
I took the fairings off to take a peek at the Spark Plugs to see if they may offer some insight to what was going on.
The bike sounds like it is missing terribly under 4k, once about that it sounds better.
I am going to have to take it to my Yamaha Dealer tomorrow and see if they can figure it out.
I will follow up
Thank you
 

Markyboy61

New Member
FYI, I did not take out the plugs. They looked like a bear to get out.
Is the only way to do it to remove the radiator ?
I have a Gen 1 FZ1 and there is plenty of room
 

BluePill

Member
Such low mileage means a lot of time sitting with stale gasoline. A friend didn't ride her 6R for two years, and the low end performance was poor. We ran it for three tank fulls with Techron added and it cleaned up like new. I suspect it was gummed up injectors. Can't hurt to give it a try.
 

Bliz

New Member
I just picked up a 2009 FZ6R (with 2,000 miles on it) for my wife to ride and it has a Two Brother exhaust system on it. It is loud but runs like a pig. From idle to about 4,000 rpm it stumbles all over the place. The bike does not have a Power Commander. I thought with a Fuel injected bike that they could compensate a bit for the pipe and you would only need a Power Commander if you wanted to really dial it in. DId I buy a bike with some other issue or does this thing need a Power Commander and fuel map.
Last year I bought a 10 year old gsx650f with 1900 miles on it. Had a low rpm miss. Fuel injector cleaner helped some, but changing spark plugs eliminated miss. You also need to change the brake fluid and coolant. The older tires get the harder the rubber gets. I replaced both tires with 2 Shinkos and not only increased safety but made a huge improvement in handling.. I have a Yoshimura exhaust on bike and it had nothing to do with the miss. Go on YouTube and someone will have a video on how to change the plugs. I'm pretty sure this will eliminate the miss. Use the plugs called for in your owners manual.
 

Markyboy61

New Member
Follow Up.
I would like to thank everyone for the feedback. I took it to my Yamaha Dealer and he looked over the whole bike and charged me $ 150.00 changed the Spark Plugs and inspect the bike. I saw the plugs and 3 looked a bit lean and one was fouled. It did resolved the issue.
The bike runs much better (especially below 4K) but I am not sure how it ran with the stock exhaust so I have no comparison.
The bike feels nice and light compared to my bike. low seat height and low center of gravity. I should be great for my wife who is a brand new rider.
It has a Two Brothers M2 with standard power tip. I ordered the P1 X power tip to try and lower the noise as it is loud as Hell. When I had it appart a couple of days ago i did see it has a brand new K&N filter in it. I wish now I just did the plugs myself.

milepig may take you up on the Offer for the stock exhaust. Where are you located, I am in Bucks County Pa.
I am also currious why you chose the Juice Box Fuel Controller ? and how much different the bike is with the FC compared to without.
Did you get the Fuel Map file from this site ?
 

milepig

Member
Follow Up.
I would like to thank everyone for the feedback. I took it to my Yamaha Dealer and he looked over the whole bike and charged me $ 150.00 changed the Spark Plugs and inspect the bike. I saw the plugs and 3 looked a bit lean and one was fouled. It did resolved the issue.
The bike runs much better (especially below 4K) but I am not sure how it ran with the stock exhaust so I have no comparison.
The bike feels nice and light compared to my bike. low seat height and low center of gravity. I should be great for my wife who is a brand new rider.
It has a Two Brothers M2 with standard power tip. I ordered the P1 X power tip to try and lower the noise as it is loud as Hell. When I had it appart a couple of days ago i did see it has a brand new K&N filter in it. I wish now I just did the plugs myself.

milepig may take you up on the Offer for the stock exhaust. Where are you located, I am in Bucks County Pa.
I am also currious why you chose the Juice Box Fuel Controller ? and how much different the bike is with the FC compared to without.
Did you get the Fuel Map file from this site ?
I live in Duluth Mn. To be honest, the 2brothers system and Juice Box just showed up at home, I had no idea she even purchased it. IIRC the Juice box only had 2 or maybe 3 setting on it, we just set it to the 2B's recommended setting and it worked just fine. She seems to get about the same mileage, although I really don't know.
 


Top