Thanks Thanks:  1
Likes Likes:  1
Dislikes Dislikes:  0
Results 1 to 9 of 9

Thread: Dash flickered then went out.

  1. #1
    Junior Member
    Join Date
    Dec 2018
    Location
    Huntington Beach ca
    Posts
    2
    Rep Power
    0

    Default Dash flickered then went out.

    So I was riding to my family Christmas party. The dashboard instrument cluster started going off and back on. As if I was turning on and off the key. But the bike would stay running Kinda it would stutter a little bit. As soon as I pulled in the parking lot the bike went off. Then nothing when I turn the key on nothing happens at all. Itís a 2009 FZ6R. The starter motor recently went bad and I had been pushed starting it. I think it could possibly be the main relay, The ECU, Or the voltage regulator. I donít have very much experience with electrical. Iím pretty dumb founded and I really need some help please anybody

  2. #2
    Senior Member
    Join Date
    Apr 2014
    Location
    Australia
    Posts
    256
    Rep Power
    5

    Default

    Quote Originally Posted by lovelife4790 View Post
    So I was riding to my family Christmas party. The dashboard instrument cluster started going off and back on. As if I was turning on and off the key. But the bike would stay running Kinda it would stutter a little bit. As soon as I pulled in the parking lot the bike went off. Then nothing when I turn the key on nothing happens at all. Itís a 2009 FZ6R. The starter motor recently went bad and I had been pushed starting it. I think it could possibly be the main relay, The ECU, Or the voltage regulator. I donít have very much experience with electrical. Iím pretty dumb founded and I really need some help please anybody
    The starter motor is also the alternator so if it's shagged the battery won't be charging which is the cause of your problems. You'll need a new stator (starter/alternator)

  3. Likes alaskanflyboy liked this post
  4. #3
    Senior Member BluePill's Avatar
    Join Date
    Sep 2009
    Location
    NW Florida
    Posts
    183
    Rep Power
    10

    Default

    Quote Originally Posted by Rumpig View Post
    The starter motor is also the alternator so if it's shagged the battery won't be charging which is the cause of your problems. You'll need a new stator (starter/alternator)
    This is false. Starter and alternator are 2 different units.

    Questions for Lovelife:

    What did you do to repair the starter?

    Have you connected any accessories to the electrical system recently?

    Lovelife: The simple checks are as follows:

    Test the battery voltage with a basic voltmeter. You can buy one for about $15 at auto parts stores, Amazon, etc. if you don't have one. The battery should be above 12.5 volts with the ignition off, and above 9.6 volts when the starter motor is engaged. If not, you probably have an undercharged or worn out battery. If you can get the bike running, you should have between 13.8 and 14.4 volts.

    Check for loose electrical connections at the battery and the wires going into the dash display.

    Beyond that, you will need a factory service manual and electrical troubleshooting skills.

    If you are willing to learn, there is a lot of info on the internet, but non-professional posts and videos are often in error. If you find a number of sources telling you the same thing, it is more than likely useful info.

    Good luck.
    Last edited by BluePill; 12-13-2018 at 09:22 PM.
    Now: 2015 FZ6R & 2008 WR250R
    Past: 2009 FZ6R & 2008 CBR1000RR

  5. Thanks Rumpig thanked for this post
  6. #4
    Junior Member Stephe's Avatar
    Join Date
    Apr 2016
    Location
    Deptford, New Jersey USA
    Posts
    5
    Rep Power
    0

    Default

    I experienced similar sounding troubles with my 2013 FZ6R this year. It took several returns to the local dealership to resolve. First 'fix' was replacing the battery. In a week or so, same troubles returned during a ride. I rode it directly to the shop, left it at their back door and walked home. The shop rode the bike everyday and couldn't get the problem to repeat. The solution was to replace both the Stator and Regulator, about $600, and have had no troubles since. Its been a great bike except for that trouble earlier this year.

  7. #5
    Senior Member alaskanflyboy's Avatar
    Join Date
    Apr 2011
    Location
    Milwaukee, WI
    Posts
    977
    Rep Power
    8

    Default

    Quote Originally Posted by BluePill View Post
    This is false. Starter and alternator are 2 different units.
    The starter and the generator are all part of the stator on the FZ6R. There is a starter clutch attached to the generator, but the generator is the motor for it. It's not uncommon bikes to be set up that way.
    Last edited by alaskanflyboy; 12-19-2018 at 12:46 AM.
    ó John

    Current Bike: 2009 FZ6R Blue/White, Shogun No-Cut Frame Sliders, Pro-Grip Tank Pad, Rascal Grafik Tank Grip
    Current Gear: HJC IS-MAX BT helmet, Fly Racing Trekker Jacket, Fly Racing Butane Pants, Cortech Adrenaline Gloves
    Mileage: 17200mi
    "A good p̶i̶l̶o̶t̶ rider is always learning."

  8. #6
    Senior Member BluePill's Avatar
    Join Date
    Sep 2009
    Location
    NW Florida
    Posts
    183
    Rep Power
    10
    Now: 2015 FZ6R & 2008 WR250R
    Past: 2009 FZ6R & 2008 CBR1000RR

  9. #7
    Senior Member alaskanflyboy's Avatar
    Join Date
    Apr 2011
    Location
    Milwaukee, WI
    Posts
    977
    Rep Power
    8

    Default

    I somehow missed the starter motor section further down in the manual. I saw the starter clutch attached to the generator and assumed it was a start/gen. Thanks for the correction.
    ó John

    Current Bike: 2009 FZ6R Blue/White, Shogun No-Cut Frame Sliders, Pro-Grip Tank Pad, Rascal Grafik Tank Grip
    Current Gear: HJC IS-MAX BT helmet, Fly Racing Trekker Jacket, Fly Racing Butane Pants, Cortech Adrenaline Gloves
    Mileage: 17200mi
    "A good p̶i̶l̶o̶t̶ rider is always learning."

  10. #8
    Junior Member
    Join Date
    Dec 2018
    Location
    Huntington Beach ca
    Posts
    2
    Rep Power
    0

    Default Got it fixed

    Quote Originally Posted by alaskanflyboy View Post
    I somehow missed the starter motor section further down in the manual. I saw the starter clutch attached to the generator and assumed it was a start/gen. Thanks for the correction.
    It ended up being the starter relay shorting out and finally burning out

  11. #9
    Senior Member BluePill's Avatar
    Join Date
    Sep 2009
    Location
    NW Florida
    Posts
    183
    Rep Power
    10

    Default

    That will do it. Glad you found the problem.
    Now: 2015 FZ6R & 2008 WR250R
    Past: 2009 FZ6R & 2008 CBR1000RR

Similar Threads

  1. fz6r dash plastics ?
    By SanDiegoRider in forum FZ6R General Discussion
    Replies: 1
    Last Post: 12-26-2015, 11:50 AM
  2. Vibration noise in the dash?
    By tcmizzou in forum Garage / Mechanical Help
    Replies: 4
    Last Post: 04-21-2012, 06:24 AM
  3. Charging USB Port Installed in Dash (anyone interested)
    By Rcnewton in forum FZ6R General Discussion
    Replies: 12
    Last Post: 03-06-2012, 06:12 AM
  4. orig front cowling inner panels (dash), black, all three pieces L/C/R
    By ctgottapee in forum Bikes/Parts For Sale
    Replies: 9
    Last Post: 01-08-2012, 03:59 PM
  5. Dash Custom Exhaust System
    By btastarsky in forum FZ6R Mods
    Replies: 3
    Last Post: 02-23-2010, 03:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •